Reserved node doesn't work

Try connect to another node with --reserved-nodes, but the connection never established

Should work, we use it actively. I think it shouldn’t, but it may refuse to connect to nodes from private IP range (like LAN) unless you allow private IPs explicitly.

I have 2 nodes, one (A) is running with default config, another (B) tries to connect to A via local ip like

Btw, how to enable private IPS

There is both Subspace networking and Substrate networking stacks in the node and there is just Subspace networking stack in farmer, you can find all CLI options by running an app with --help.

Also note that both nodes should add each other to reserved for feature to work properly.

doesn’t work for me even though I enabled the --dsn-enable-private-ips --allow-private-ip.

Another question, my full synced node can not catch up the chain header easily every time I restart it, what’s the reason?

You’d need to provide commands from all nodes you’re running, I can’t guess what is happening there.

Can you be more specific? Vague descriptions of a problem are not possible to diagnose in most cases.

For 1st node, ./subspace-node --rpc-cors all --out-peers 100 --in-peers 100 --rpc-methods unsafe --rpc-external --chain gemini-3f --execution wasm --blocks-pruning archive --reserved-nodes /ip4/ --rpc-port 11011 --dsn-enable-private-ips --allow-private-ip --state-pruning archive --validator --base-path $DATA.
For 2nd node, ./subspace-node --rpc-cors all --out-peers 100 --in-peers 100 --rpc-methods unsafe --rpc-external --chain gemini-3f --execution wasm --blocks-pruning archive --reserved-only --reserved-nodes /ip4/ --dsn-enable-private-ips --allow-private-ip --state-pruning archive --validator --base-path $DATA --dsn-listen-on /ip4/

This is DSN IP/port, it is not the same port as Substrate uses, this is your problem. For Substrate networking you should use --listen-addr instead. Yes, there are two networking stacks in the node.

Reserved-node works only if both they add each other as reserved-node? I remember it works in another way in last testnet.

It always worked that way. I’m not sure what you’re trying to achieve here though, it’ll likely be useless, meaning it will only slightly decrease the network communication and increase the network latency for the second node. Not entirely sure why are you even bothering with it.

I’m sure this is a different way, I’m top5 miner for both last 2 testnets. Anyway, doesn’t matter.