Node knocks out internet in whole house

would you mind trying the unified cli? We have been testing and it appears that the unified cli is less intensive on networks. (running separately results in two instances of the Decentralized Storage Network, where as the unified cli only uses one)

Would love to hear your feedback with this version comparatively to the pathway you have been using in the past.

The dev team is also working on some improvements for this which we hope to have implemented in the near future

I was just reading up on it, seems really easy for beginners. I will give it a shot. Is it gpu assisted?

1 Like

Yes it will utilize gpu for plotting the same as our normal binaries

I tried the cli and it seems to have synced without me having internet issues! But then it crashed after syncing. Error is below.

Node started successfully!
◟ [05:38:36] 100% [█████████████████████████████] (375331/375331) 18.47bps, Syncing is done!, ETA: 00:00:00 Starting farmer …
The application panicked (crashed).
Message: Should be populated at this point.
Location: C:\Users\runneradmin.cargo\git\checkouts\subspace-5c1447fb849a5554\cea0fd5\crates\subspace-farmer\src\utils\

Backtrace omitted. Run with RUST_BACKTRACE=1 environment variable to display it.
Run with RUST_BACKTRACE=full to include source snippets.
Farmer started successfully!
Initial plotting for plot: #0 (C:\Chia.Temp\RAID0\Subspace)
◠ [00:00:00] 0% [ ] (32.00 MiB/8.09 TiB) 145.21 GiB/s, plotting, ETA: 00:00:57

Just trying to keep you up to date. The CLI worked without knocking out the internet but it synced very slowly. Also it would say it was synced every once in awhile but it obviously was not. It would start plotting then crash, I’m assuming due to it wasn’t really synced. I would shut down and start again and it would continue syncing from the last point. This got old having to babysit it so I’m going back to the advanced version which I prefer anyway due to the use of multiple hard drives. I see this new version has a fix for the network issues.

gemini-3c-2023-mar-07 Pre-release

Small update, fixes command for chain purging on the node and makes DSN networking a bit more conservative, hopefully improving situation with software causing networking issues for some users.

I am testing this version now and will report back, I’m going to let the node fully sync first before starting the farmer. It seems to by syncing 100% faster than the cli.

I have experienced similar symptoms to the OP’s title - running a node via CLI would cause all devices on the network to lose Internet connectivity after a while. I managed to get round the issue by removing the ISP supplied router from my WAN setup. Somehow that was the weak link.

I’m not sure what the root cause is but wanted to document my experience in case anyone else searches these symptoms.

The latest investigations on this issue suggest that the root cause may be related to the number of DNS queries being made to the boostrap nodes. If anyone is able to provide any insights into what exactly is happening on their network when the symptoms are present they will be gratefully received as they are super useful in narrowing down the scenario.

I’m seeing the same with subspace-cli-Ubuntu-x86_64-v0.1.8-alpha unified CLI. I was half an hour + on the phone with my internet provider before it came to me that I’ve started the node this morning :sweat_smile: After killing it internet started working again. The symptoms where very confusing with some computers failing to connect to wifi, others connecting but having unstable access.
Let me know what kind of information I can provide to help figuring this out.

1 Like

I’m testing out the advanced release now with the new flags, I have it set to 5 in and 5 out. It seems to help the situation.

–dsn-max-in-connections 5
–dsn-max-out-connections 5


Ed, Punk

Still no joy when testing with this release?:Release gemini-3c-2023-mar-15 · subspace/subspace · GitHub

Working fine with the new flags for me, I set to 5 in and 5 out. I even tested it with 100 peers in and it still worked fine.



Many thanks for the feedback!

I’ve started with the advanced march 15 release earlier today with the default dsn settings. It seems fine up to now network wise, although I’ve killed the farmer for another reason: Gemini 3a prerelease testing - Couldn't get a piece from DSN - #9 by edbaff1ed

I’ll report here if I see more issues with the network. Thanks.

Using the defaults still breaks my network. I’m trying the dsn flags as suggested by PuNkYsHuNgRy .

so default subspace-cli v0.1.9-alpha reached out all active connection on my home router
for example: Keenetic Speedster (KN-3012)
after subspace node started in my GUI router i saw active connections 16384/16384. (~2k active connection without running subspace)
and it’s really disturb to use network at home (no new connections possible)

Only stop node and restart router - quick method to make home on-line :C

Yeah no luck here either even with the dsn settings. This time I’ve killed the farmer and let the node going and I got the network back.

There was a spike in TCP connections around the time the network went down as seen in the graph.

@Fradique Is this something the dev team is looking into? Any clues at this point?

Hello Ed

Correct. A known issue escalated to devs. I appreciate your patience.

May be add this to hosts file will reduce workload on router  bootstrap-0  bootstrap-1  bootstrap-2 

I’ve been using gemini-3c-2023-mar-23 with default settings for a few days now and my network isn’t breaking down. I still see ocasional errors while browsing the internet although I’m not completely sure I can attribute to subspace node/farmer.
@Hoan_Wu do you think adding those entries to the host file is still relevant for gemini-3c-2023-mar-23? Can you shed some light on what those bootstrap domains are used for? Thanks.