Node knocks out internet in whole house (Gemini 3h)

Issue Report


  • Operating System: Ubuntu 20.04
  • Pulsar/Advanced CLI/Docker: Advanced CLI, gemini-3h-2024-feb-05


In Gemini 3h as far as I understand, the farmer creates a large number of connections and my router can’t handle it.
Used CPU 55%
RAM used 50% (64/128 mb)
Active connections 16384/16384

All service-daemons have the same non subspace options:


And these subspace options:

NODE daemon

ExecStart=/usr/local/bin/subspace-node run --chain gemini-3h --base-path=/root/subspace/subspace-node/   --blocks-pruning 256   --state-pruning archive  --name "zug" --rpc-listen-on --rpc-methods unsafe --rpc-cors all --rpc-max-connections 128 --listen-on /ip4/ --dsn-listen-on /ip4/ --dsn-listen-on /ip4/

LOCAL farmer daemon

ExecStart=/usr/local/bin/subspace-farmer farm --reward-address *ADDRESS* --node-rpc-url ws:// path=/media/andrew/1tbssd/plots/1,size=455G path=/media/andrew/1tbssd/plots/2,size=455G path=/media/andrew/ssd2/plots/1,size=455G path=/media/andrew/ssd2/plots/2,size=465G path=/media/andrew/nvme1/plots/1,size=950G


ExecStart=/usr/local/bin/subspace-farmer farm --reward-address *ADDRESS* --listen-on /ip4/ --node-rpc-url ws:// path=/media/andrew/nvme0/plots/1,size=933G path=/media/andrew/nvme1/plots/1,size=933G


Playing with the –in-connections and –out-connections parameter in farmer helps a little but but doesn’t solve the problem completely.

For example screenshot from GUI my router (Keenetic Speedster)

All farmers and node working:
all works

Node and 1 farmer

All subspace turn off:

Subspace doesn’t create anywhere near that amount of connections. What it does though is opening and closing connections quite often. So depending on how quickly router “forgets” corresponding states, it might become overwhelmed.

In pfSense in “System / Advanced / Firewall & NAT” there is an option “Firewall Optimization Options”. IT should normally be set to “Normal”, but if you set it to “Conservative” you’ll see A LOT more memory and CPU usage as router tries to keep up with a lot of connections. There might be a similar option in your router as well.