Verification failed for block, Header rejected: too far in the future

Hello, is this something to be concerned about?

2022-06-23 15:42:05 [PrimaryChain] :broken_heart: Verification failed for block 0x082b1a6a57ce6b0c552456bdc8e0f1ac8fc40cac45334895bf0db2a433994b80 received from peer: 12D3KooWANjna6aRcSTGRASfEjVqKbocMTFexQSPmkjCUWMsfgjm, “Header 0x082b1a6a57ce6b0c552456bdc8e0f1ac8fc40cac45334895bf0db2a433994b80 rejected: too far in the future”
2022-06-23 15:42:05 [PrimaryChain] :broken_heart: Verification failed for block 0x082b1a6a57ce6b0c552456bdc8e0f1ac8fc40cac45334895bf0db2a433994b80 received from peer: 12D3KooWETumSmrNPJ4SBZGFRdzPh1DC6XqBXp4Jz8fDqabYBo7E, “Header 0x082b1a6a57ce6b0c552456bdc8e0f1ac8fc40cac45334895bf0db2a433994b80 rejected: too far in the future”

Occasionally you may see this error from various forks, did the node continue to operate properly after this error?

Continues to show that error. Are these from peers that don’t run their system on synced clock? What is the impact when a peer isn’t synced with time (for example via ntp) and produces blocks with a future time? Future as compared with global time.

2022-06-23 21:56:04 [PrimaryChain] :zzz: Idle (41 peers), best: #340090 (0xf676…89e2), finalized #339990 (0x474c…dea0), :arrow_down: 666.3kiB/s :arrow_up: 393.0kiB/s
2022-06-23 21:56:05 [PrimaryChain] :broken_heart: Verification failed for block 0xf5c978e7e8211ad8b106efed5e4dafc135b420c5e233f463a9ba3f26c6e7bdfe received from peer: 12D3KooWQ5xHCaF9CbnUT3pDPqParEmh9j5P13uMmppyb7t9Ym4L, “Header 0xf5c978e7e8211ad8b106efed5e4dafc135b420c5e233f463a9ba3f26c6e7bdfe rejected: too far in the future”
2022-06-23 21:56:05 [PrimaryChain] :broken_heart: Verification failed for block 0xf5c978e7e8211ad8b106efed5e4dafc135b420c5e233f463a9ba3f26c6e7bdfe received from peer: 12D3KooWBrmAzp2Wg4Vm6j4SdciydV7mJ6RdPXXWXutw5cRVktvj, “Header 0xf5c978e7e8211ad8b106efed5e4dafc135b420c5e233f463a9ba3f26c6e7bdfe rejected: too far in the future”

this is entirely possible, (i assumed you checked, but it can also be caused when your system ntp is off)

You could try increasing --out-peers to allow more node connections which should hopefully deliver the proper blocks

I may try the --out-peers option. A restart of the node helped to. Yes time is synced

[root@node-2d ~]# timedatectl
Local time: Thu 2022-06-23 22:28:46 EDT
Universal time: Fri 2022-06-24 02:28:46 UTC
RTC time: Fri 2022-06-24 02:28:47
Time zone: America/New_York (EDT, -0400)
System clock synchronized: yes
NTP service: active
RTC in local TZ: no