V0.4.0-alpha - start error

Issue Report


  • Operating system: Ubuntu 20.04
  • CPU: Ryzen 9 5950x
  • RAM: 128Gb DDR4 3000MHz
  • Disk: Adata XPG8200 Pro, 2Tb, SSD NVMe
  • Plot-size: 300Gb
  • Deploy: Subspace Cli, v0.4.0-alpha


Farmer start error

Expected result

Expected result? I don’t even know. Maybe give me the most glittering medal (lol). Or at least correct this mistake.

What happens instead

[Paste error here]

Initial plotting for plot: #0 (/root/.local/share/subspace-cli/plots)
[00:00:00] 100% [████████████████████████████████████████] (286.10 GiB/286.10 GiB) Initial plotting finished!
0: solution subscription crashed
1: couldn’t update summary
2: TOML parse error at line 1, column 1
2: |
2: 1 | initial_plotting_finished = true
2: | ^
2: invalid key


━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ SPANTRACE ━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

0: subspace_cli::summary::parse_summary with self=SummaryFilePointer { file: Mutex { data: “/root/.local/share/subspace-cli/summary.toml” } }
at src/summary.rs:154
1: subspace_cli::summary::update with self=SummaryFilePointer { file: Mutex { data: “/root/.local/share/subspace-cli/summary.toml” } } is_plotting_finished=false is_new_block_farmed=false is_new_vote=false maybe_new_reward=None
at src/summary.rs:118

Suggestion: If you think this is a bug, please submit it to our forums: https://forum.subspace.network


I tried to run it on a second computer - the result is the same.
Second home computer:
Operation system - Ubuntu 22.04
CPU - E5-2696v3*2
RAM - 128Gb DDR3
Disk - node+system - SSD NVMe Adata XPG8200Pro, plot - ssd-sata micron 5210 ion
Plot-size - 6Tb


Starting farmer …
Farmer started successfully!
Initial plotting for plot: #0 (/mnt/micron/subspace-cli/plots)

0: waiting on farmer failed
1: solution subscription crashed
2: parsing the summary failed
3: couldn’t read the contents of the summary file
4: Bad file descriptor (os error 9)


━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ SPANTRACE ━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

0: subspace_cli::summary::parse with self=SummaryFile { inner: Mutex { data: tokio::fs::File { std: File { fd: 1157, path: “/root/.local/share/subspace-cli/summary.toml”, read: false, write: true } } } }
at src/summary.rs:109

Suggestion: If you think this is a bug, please submit it to our forums: https://forum.subspace.network

Backtrace omitted. Run with RUST_BACKTRACE=1 environment variable to display it.
Run with RUST_BACKTRACE=full to include source snippets.

PS. subspace-cli wipe (summary) was done.
P.S.S: I tried two options:
1 - build the binary on my computer
2 - download the ready-made one from github

1 Like

That’s true. Thanks for the bug report. We also have identified the issue and fixed it!
New release is on the way!


Ahahaha) I will find more bugs

1 Like

New release is available :smiley:

Ok, Justin, I ran off to test it, but I’ll be back with a list of bugs anyway.