Syncing paused while plotting continues - Pulsar 0.6.13 on Windows

Farmer synchronization has frozen on block 433,631 and will not make progress.

After some time the farmer will stop attempting to sync and move on to plotting. There is no problem with plotting and the farmer shows that I have plotted 93.13 GB but it is only caught up to block 433,631.

The error hasn’t been resolved by updating versions of Pulsar or by re-initializing the farmer and increasing the plot size from 50 → 100 GB.

Can I resume syncing without wiping the plot?

@Parth something for you to look into.

BTW, are you really on HDD or is it just Windows showing it that way?
Because it is extremely unlikely to farm on HDD anything at all.

1 Like

Hmm. Strange. Can you send me last 1k lines of log? Would help us narrow down the issue.

1 Like

Unfortunately I am. Just testing the machine though while I wait for the SSD to ship in

Yes here are the logs from today: 1k lines for Parth -

I wouldn’t bother testing then, it will not work, basically guaranteed.

As to the actual issue, it is possible that might have hit Node can't sync with the network · Issue #493 · paritytech/polkadot-sdk · GitHub that is still not resolved. Eventually when new segment of history is archived you’ll be able to bypass that with sync from DSN, but until then you might be stuck.

1 Like

After replacing the HDD with an SSD, there was no difference. Even when I wiped the farm, it would not connect.

But, I was able to resume syncing by disabling the Microsoft Defender Firewall. I did not have that problem on another farm running Windows, so I’m not sure how that became relevant midway through syncing, or how it was possible for plotting to continue.

Either way, I’m glad that it works now. In hindsight, disabling the firewall should have been the first thing I checked :joy: