Slowed plotting speed for mining due to an excessive number of physical SSDs

I’ve been struggling with slow plotting speeds recently. On my server, I have 24 nvmeSSDs. When I unplugged 12 of them, leaving only 12 nvmeSSDs, the plotting speed greatly improved. I suspect there might be some I/O read/write limitations causing this issue. However, I believe this problem should be solvable with a large amount of RAM. When I reverted to an older version, it indeed worked as expected. My server has up to 1TB of RAM; the older version could utilize around 800GB, but the current version only uses 2-8GB. I understand that most people might not have this much RAM, but is it possible to allow both RAM usage methods to coexist? Or can I modify some source code or parameters to enable the farming program to utilize more RAM?

I don’t understand why would farmer ever use 800G of RAM, that makes no sense to me. Also it would help to know what “new” and what “old” versions you’re talking about exactly.

Either way plotting speed in most cases is CPU-bound, not memory. Farmer can potentially use more memory for some things, but it is very unlikely that plotting speed will improve from that. At least that is true for consumer CPUs.

If you have more exotic setup with 1T of RAM, we are still happy to improve situation there, but I hope you understand that you’ll have to help us with that as it is not quite the primary concern for us to support such configurations.

The essential takeaway is that reducing the quantity of physical SSDs on the server can enhance the plotting speed.

I have already found a solution. I made some changes in the BIOS settings. Please disregard my question.

Would you mind sharing the findings with others?

There are many settings involved, and I am currently testing. I’ve found that it’s related to the CPU’s performance mode. When the CPU is only used at 70%, the plotting speed is very fast. However, when the CPU usage reaches 90%, the plotting speed becomes much slower because the frequency drops from 3.6 to 2.8.

need to lock the CPU in high-performance mode in the BIOS.

@nazar-pc probably he did not take into consideration 2 crucial things:
a) Amount of L3 cach per core availiable for CPU
b) TDP & EDP of CPU when 100% used

in both situations it leads to a decrease of CPU effectivenes. In both situations disabling mutithreading solve the problem, but in every case it require additional consideration and optimization.

I tried disabling multithreading, but it didn’t work well,

what CPU you utilize?

EPYC 7V13*2

The CPU I use