Pulsar: `info` subcommand outputs an obsolete plot size


After changing the plot size in settings.toml and restarting the node, the pulsar info command continues to output the past plot value. The pulsar farm displays the correct value.

Steps to reproduce:

  • Run pulsar init.
  • Run pulsar farm and and wait for synchronisation to complete and plotting to begin.
  • Run pulsar info and check the plot size value.
  • Change plot size in settings.toml.
  • Run pulsar farm again, wait for plotting to resume and stop it.
  • Run pulsar info and check the plot size value.

@Parth this is something for you to take a look at

I believe this can be resolved by wiping the summary file as it holds on to some of these values such as plot size in addition to the settings.toml.

Also waiting Parths insights, but this may be a temporary workaround.

@ImmaZoni This should potentially work. Let me take a look.