Instructions doesn't specify commands to restart a node


In case node shuts down by the accident, or some change was made to the config, I can’t restart the node by running a farm command

System Information

Windows 10, Intel Core i5 10400F, 16GB Ram

Steps to reproduce:

Complete initiation and start farming
Stop the farmer
Try resume farming


Complete initiation and start farming
Stop the farmer
Initiate the node again with different params (e.g. plot size)
Try resume farming

Actual Results:

The error I’m getting is “Failed to Subscribe to node syncing: failed to connect to the network”

1 Like

@ozgun not sure if you would consider this a bug or an improvement, thoughts?

Seems like a connection issue, because the node was unable to connect to the network. I’ve been able to change the config and restart the node.
Cannot reproduce this error at the moment.

I don’t think it’s related to Windows10, however we should try.

Thanks for the report @Emilios , if you can find the time, could you please retry and see if this error is still present?

Thanks Ozgun.
I’ve tried restarting the node multiple times, double-checked the firewall and ports.
Tried wiping the data and starting from scratch, the error still persists.

As per Justin recommendation, used --verbose flag

And second image:

Try after wipe - still persists.

These are very useful for debugging. Let me summarize my inferences:

  1. if this happens even after wipe, than it is not related to farm command being interrupted or node failed before. The problem is simply: node is unable to start

  2. I still cannot reproduce the error and haven’t seen this error for other people yet. It could be that your configuration is malformed or something specific to your machine.

So, just to be sure, I will ask 2 things:

  • can you share your config file in here? Your config file should be at location: C:\Users\{YourUserName}\AppData\Roaming\subspace-cli

  • and if you haven’t tried, please try this:

    1. wipe (you already did this)
    2. init (but if you haven’t init after wipe, try this :slight_smile: )
    3. farm (now, it should work imo, because I’m suspecting of ill-formed config file at this point, init should rewrite the config file from scratch, so farm should work after wipe, then init)

If this won’t help, I’m suspecting of something local, keep us posted!
Appreciated your time and effort on this, I will try to provide my best help as I can :tada:


Thank you Ozgun, I was finally able to start a node.

I have a dual-band router and, by default, machine decides what band to connect to (I had only one wi-fi working in dual-band mode if that makes sense).

Since I was investigating the issue, I enabled the function on a router so that two bands were running separately (2.4 GHz, and 5 GHz). When connected to 2.4 GHz the node showed the same error as posted above, while connecting to 5 GHz worked started successfully from the first try.

So it was indeed an issue of a local network, but still trying to figure out whether the latency on one of the bands was too long or what exactly affected starting the node.

But overall, sync has done within 14 minutes, now I’m up plotting!

Excuse me mates, I’m curious, did you still have internet when connected to 2.4 GHz? Obviously yes… so it was possible only if you have some connection restrictions on 2,4 channel. I’d like to investigate this issue, - wouldn’t you mind to tell me your router model?

1 Like

Since then the node works correctly in both 2.4 GHz and 5 GHz, so the issue seem to be resolved. But if you’re curious my modem is Hitron 4582