Illegal instruction (core dumped)

When I run CLI-0.2.0-V2 for gemini 3D ,it shows "Illegal instruction (core dumped) "
My cpu : E5-2690V2
It dont support for this old CPU ?

Gemini 3d isnt fully launched, currently we are on gemini-3c you can utilize our documentation here for the correct version: Simple CLI (Recommended) | Farm from Anywhere

1 Like

Hello. Gemini 3d fully running, problem with old CPU not solved ?

How old is your CPU? can you provide your system specifications? Also what version of the CLI are you using?

CPU Intel Core i5-2400
RAM 16GB
SSD 1Tb
subspace-cli-ubuntu-x86_64-v2-v0.3.3-alpha

also a problem
RAM 16 GB
SSD 1Tb

stelss@stelsserver:~$ lscpu
Architecture: x86_64
CPU op-mode(s): 32-bit, 64-bit
Address sizes: 46 bits physical, 48 bits virtual
Byte Order: Little Endian
CPU(s): 4
On-line CPU(s) list: 0-3
Vendor ID: GenuineIntel
Model name: Intel(R) Xeon(R) CPU E5-1603 0 @ 2.80GHz
CPU family: 6
Model: 45
Thread(s) per core: 1
Core(s) per socket: 4
Socket(s): 1
Stepping: 7
CPU max MHz: 2800,0000
CPU min MHz: 1200,0000
BogoMIPS: 5586.51
Flags: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx pdpe1gb rdtscp lm constant_tsc arch_perfmon pebs
bts rep_good nopl xtopology nonstop_tsc cpuid aperfmperf pni pclmulqdq dtes64 monitor ds_cpl vmx smx est tm2 ssse3 cx16 xtpr pdcm pcid dca sse4_1 sse4_2 x2apic popcnt tsc_deadline_
timer aes xsave avx lahf_lm epb pti ssbd ibrs ibpb stibp tpr_shadow vnmi flexpriority ept vpid xsaveopt dtherm arat pln pts md_clear flush_l1d
Virtualization features:
Virtualization: VT-x
Caches (sum of all):
L1d: 128 KiB (4 instances)
L1i: 128 KiB (4 instances)
L2: 1 MiB (4 instances)
L3: 10 MiB (1 instance)
NUMA:
NUMA node(s): 1
NUMA node0 CPU(s): 0-3
Vulnerabilities:
Itlb multihit: KVM: Mitigation: VMX disabled
L1tf: Mitigation; PTE Inversion; VMX conditional cache flushes, SMT disabled
Mds: Mitigation; Clear CPU buffers; SMT disabled
Meltdown: Mitigation; PTI
Mmio stale data: Unknown: No mitigations
Retbleed: Not affected
Spec store bypass: Mitigation; Speculative Store Bypass disabled via prctl and seccomp
Spectre v1: Mitigation; usercopy/swapgs barriers and __user pointer sanitization
Spectre v2: Mitigation; Retpolines, IBPB conditional, IBRS_FW, STIBP disabled, RSB filling, PBRSB-eIBRS Not affected
Srbds: Not affected
Tsx async abort: Not affected

1 Like

@stelss & @S1ned888 Are you both using the “subspace.sh” i see in the intial post screenshot? If so would you mind posting this .sh script as its not something we maintain.

Have you tried utilizing our default documentation?

You can find our Documentation at: https://docs.subspace.network

I’m also using the ‘subspace.sh’ script from the initial post and I’m having the same issue.
I have a Intel Xeon E5-1650v2

The script can be found here: https://api.nodes.guru/subspace_v2.sh

Basically what it does is automating the steps in the official docs, including installing dependencies and setting it up as a service. At the time of writing, it uses the latest subspace-cli-ubuntu-x86_64-v2-v0.3.3-alpha executable.

I’m having the same issue with Version 3 - For newer processors since ~2015

1 Like

Hello,
same problem here, the v2-v0.1.12 version was working fine for Gemini 3c. Restart from zero for Gemini 3d version v2-v0.3.3-alpha, core dump.
I use this command:

./subspace-cli-ubuntu-x86_64-v2-v0.3.3-alpha farm

No error in the logs. In trace mode, the last logs are:

{"v":0,"name":"subspace-cli","msg":"Processed commit 2 (record 5), 0 ops, 14 bytes written","level":20,"hostname":"ubiknode3","pid":1489,"time":"2023-04-25T19:42:08.728414274Z","target":"log",
"line":null,"file":null,"log.target":"parity-db","log.module_path":"parity_db::db","log.file":"/home/runner/.cargo/registry/src/index.crates.io-6f17d22bba15001f/parity-db-0.4.6/src/db.rs","log
.line":494}
{"v":0,"name":"subspace-cli","msg":"[RUNTIME.SPAWN - START]","level":10,"hostname":"ubiknode3","pid":1489,"time":"2023-04-25T19:42:08.756546765Z","target":"tokio::task","line":16,"file":"/home
/runner/.cargo/registry/src/index.crates.io-6f17d22bba15001f/tokio-1.27.0/src/util/trace.rs"}

RAM 8 go
SSD 256 go
lscpu

Architecture:                    x86_64
CPU op-mode(s):                  32-bit, 64-bit
Byte Order:                      Little Endian
Address sizes:                   39 bits physical, 48 bits virtual
CPU(s):                          4
On-line CPU(s) list:             0-3
Thread(s) per core:              1
Core(s) per socket:              4
Socket(s):                       1
NUMA node(s):                    1
Vendor ID:                       GenuineIntel
CPU family:                      6
Model:                           122
Model name:                      Intel(R) Pentium(R) Silver N5030 CPU @ 1.10GHz
Stepping:                        8
CPU MHz:                         796.691
CPU max MHz:                     3100,0000
CPU min MHz:                     800,0000
BogoMIPS:                        2188.80
Virtualization:                  VT-x
L1d cache:                       96 KiB
L1i cache:                       128 KiB
L2 cache:                        4 MiB
NUMA node0 CPU(s):               0-3
Vulnerability Itlb multihit:     Not affected
Vulnerability L1tf:              Not affected
Vulnerability Mds:               Not affected
Vulnerability Meltdown:          Not affected
Vulnerability Mmio stale data:   Not affected
Vulnerability Retbleed:          Not affected
Vulnerability Spec store bypass: Mitigation; Speculative Store Bypass disabled via prctl and seccomp
Vulnerability Spectre v1:        Mitigation; usercopy/swapgs barriers and __user pointer sanitization
Vulnerability Spectre v2:        Mitigation; Enhanced IBRS, IBPB conditional, RSB filling, PBRSB-eIBRS Not affected
Vulnerability Srbds:             Not affected
Vulnerability Tsx async abort:   Not affected
1 Like

@nazar-pc & @ozgun seeing this popup for a few users now, at first thought it was related to the nodeguru subspace.sh script but appears to be popping up for users using the cli aswell.

This has been happening for a while and is caused by old CPUs without necessary instructions support (ADX specifically). Can be fixed by compiling software from source on that machine.

Official builds mention in release notes that Haswell and older CPUs (and similar, which N5030 is in terms of instruction support) are not supported at the moment.

They will be in the future (in Gemini 3e), but processors without ADX instructions support will be impacted significantly in terms of performance and will be in disadvantage comparing to processors that do support ADX instructions.

Whether it is critical or not do not know yet, but any modern desktop processor starting with Broadwell on Intel side and Ryzen (ZEN 1) on AMD side do support it. N5030 is running a special low-power architecture and doesn’t support these a bit more advanced instructions, but successors from Tremont microarchitecture might actually support it (N6xxx processors).

2 Likes

Ok thanks for the clear explanation. I’ll change the unit to a CPU that support ADX or I can compile from source if you prefer that some of the test nodes use this type of CPU for your test.