Error: Parse error: missing field maxPlotSize

I am attempting to start the farmer with the CLI binaries and getting the following error

←[2m2022-05-31T15:31:19.626758Z←[0m ←[32m INFO←[0m ←[2msubspace_farmer::commands::farm←[0m←[2m:←[0m Connecting to node at ws://
←[2m2022-05-31T15:31:19.628021Z←[0m ←[32m INFO←[0m ←[2mjsonrpsee_client_transport::ws←[0m←[2m:←[0m Connection established to target: Target { sockaddrs: [], host: "", host_header: "", _mode: Plain, path_and_query: "/" }
Error: Parse error: missing field maxPlotSize

Caused by:
    missing field maxPlotSize

Running Windows

I have usually seen this error occur when there is a firewall blocking the farmer. Try adding the farmer to the firewall allow list like below

  1. Hit the Start key
  2. Allow an app through Windows firewall
  3. Click Change Settings
  4. Find the name of the farmer .exe you are running (eg. subspace-node-windows-x86_64-snapshot-2022-mar-03.exe)
    a. If you do NOT see the farmer.exe listed click Allow another app and find the proper .exe
  5. Click the Allow checkbox

You should now be able to run the farmer with no issues.